• ⚙️ 3rd & 4th Gen Toyota Tacomas | Tacoma3G

    🌮 Tacoma3G.com is an online resource and community for 2016+ Toyota Tacoma owners.

    👤 Registration is completely free and only takes a few seconds, so we hope to see you and your rig on the forum!

    ♥️ Beginner friendly. Tight-knit. No ads. The raddest. Read more about us...

Water Troubles

AZ_CAVALRY

8️⃣ Paragon
Rig of the Month
Tacoma3G O.G.
T3G Member
#309
Messages
320
Reaction score
3,279
Location
Tolleson, AZ
First Name
Josh
Truck Year
2019
Truck Color
Cavalry Blue
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@az_cavalry
Saturday I went driving through lots of water crossings with a big group. Some water splashed on top of the hood, but was mainly slider-deep. After one of the deeper puddles, my truck stopped and lost all power. Check engine light, oil temp light, and transmission light all came on instantly. I couldn't rev over 1500 rpm without it stalling out. I disconnected the battery and reset the code. Once I restarted the truck, water sprayed out from under the hood (not sure where from), and after revving it up a few times it cleared out the water. I tried to find out what could cause the limp mode that happened, and I couldn't find much. Only thing I could find was a 2012 Tacoma having issues with the secondary air pump valve sucking in water.

Anyone have ideas on what it could be? I don't really want to take it in to the dealer and tell them I drove through four feet of water, but if I have to I will.
1550524504097.png
 

ShikyoX

6️⃣ Aficionado
Tacoma3G Supporter
T3G Member
#310
Messages
823
Reaction score
747
Age
34
Location
B.C Canada
First Name
Trevor
Truck Year
2017
Truck Color
Magnetic Gray
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@shikyox
Saturday I went driving through lots of water crossings with a big group. Some water splashed on top of the hood, but was mainly slider-deep. After one of the deeper puddles, my truck stopped and lost all power. Check engine light, oil temp light, and transmission light all came on instantly. I couldn't rev over 1500 rpm without it stalling out. I disconnected the battery and reset the code. Once I restarted the truck, water sprayed out from under the hood (not sure where from), and after revving it up a few times it cleared out the water. I tried to find out what could cause the limp mode that happened, and I couldn't find much. Only thing I could find was a 2012 Tacoma having issues with the secondary air pump valve sucking in water.

Anyone have ideas on what it could be? I don't really want to take it in to the dealer and tell them I drove through four feet of water, but if I have to I will.
1550524504097.png
How high is you truck mainly slider height but 4 feet or water:eek:
 
Upvote 0

AZ_CAVALRY

8️⃣ Paragon
Rig of the Month
Tacoma3G O.G.
T3G Member
#309
Messages
320
Reaction score
3,279
Location
Tolleson, AZ
First Name
Josh
Truck Year
2019
Truck Color
Cavalry Blue
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@az_cavalry
How high is you truck mainly slider height but 4 feet or water:eek:
I think I was exaggerating a little. Haha but it definitely splashed into the grille area and over the hood.
 
Upvote 0

ShikyoX

6️⃣ Aficionado
Tacoma3G Supporter
T3G Member
#310
Messages
823
Reaction score
747
Age
34
Location
B.C Canada
First Name
Trevor
Truck Year
2017
Truck Color
Magnetic Gray
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@shikyox
AZ_CAVALRY AZ_CAVALRY taco_ did you ever find out what caused your limp issue?
 
Upvote 0

WarFabArmor

6️⃣ Aficionado
Tacoma3G Supporter
T3G Member
#2,711
Messages
459
Reaction score
946
Location
Montrose, Colorado
First Name
Mike
Truck Year
2016
Truck Color
Barcelona Red
Truck Grade
SR5
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@W.a.r._fab
YouTube
/Warfab inc.
There are a ton of sensors you could have mucked up that would cause the truck to freak out. Even a goofy trans temp sensor will cause truck to shut down to save itself. Possibilities are nearly endless, especially if you hit water with speed and were splashing it everywhere.
 
Upvote 0

ShikyoX

6️⃣ Aficionado
Tacoma3G Supporter
T3G Member
#310
Messages
823
Reaction score
747
Age
34
Location
B.C Canada
First Name
Trevor
Truck Year
2017
Truck Color
Magnetic Gray
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@shikyox
I went in limp mode once, went in R and gunned it hahahaha
 
Upvote 0

AZ_CAVALRY

8️⃣ Paragon
Rig of the Month
Tacoma3G O.G.
T3G Member
#309
Messages
320
Reaction score
3,279
Location
Tolleson, AZ
First Name
Josh
Truck Year
2019
Truck Color
Cavalry Blue
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@az_cavalry
AZ_CAVALRY AZ_CAVALRY taco_ did you ever find out what caused your limp issue?
I never could figure out what the issue was. My guess is it is hitting one of the sensors like WarFabArmor WarFabArmor mentioned. On a side-note, I got rear-ended last week, nothing bad but one of my backup sensors went out, and my airbag light/seatbelt light came on the dash. I had the dealer run codes after this, and nothing came up related to the water issues mentioned before. I guess I will just have to take it easy next time I'm in water.
 
Upvote 0

AZ_CAVALRY

8️⃣ Paragon
Rig of the Month
Tacoma3G O.G.
T3G Member
#309
Messages
320
Reaction score
3,279
Location
Tolleson, AZ
First Name
Josh
Truck Year
2019
Truck Color
Cavalry Blue
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@az_cavalry
So, this same issue happened to me again while on a Death Valley trip over the weekend. One of the guys I was with was able to read codes, and this is what came up. Has anyone heard of these issues? Is it odd it's coming up on multiple random cylinders? I'm taking it to the dealer next week sometime for oil change, so I will bring it up to them when I go.



IMG_0280.JPG
 
Upvote 0

ShikyoX

6️⃣ Aficionado
Tacoma3G Supporter
T3G Member
#310
Messages
823
Reaction score
747
Age
34
Location
B.C Canada
First Name
Trevor
Truck Year
2017
Truck Color
Magnetic Gray
Truck Grade
Off-Road
Cab & Bed
Double Cab, Short Bed
Transmission
Automatic
Instagram
@shikyox
So, this same issue happened to me again while on a Death Valley trip over the weekend. One of the guys I was with was able to read codes, and this is what came up. Has anyone heard of these issues? Is it odd it's coming up on multiple random cylinders? I'm taking it to the dealer next week sometime for oil change, so I will bring it up to them when I go.



IMG_0280.JPG
Possibly dirty maf
 
Upvote 0