GRILLES TRD Pro Grille - TSS Issue

  • Hello, visitor! You've found the only 3rd Generation Toyota Tacoma forum! 🤙
    Tacoma3G.com is an online forum for 2016-2021 Toyota Tacoma and overland enthusiasts. Our resources include: build threads, tutorials, gear reviews, exclusive discounts and giveaways, a marketplace to buy and sell items, local trail events, and more. We have thousands of friendly, knowledgeable members, including many officials from your favorite companies. Registration is completely free and only takes 30 seconds, so we hope to see you and your rig soon!

hallux

= IV • Gold
Messages
237
First Name
Das Big Toe
T3G Member
#1,649
I should start by saying that, I've got a champagne taste on a water budget so I went with an eBay TRD Pro Grille... the quality is decent but as expected I'm having an issue with intermittent TSS warnings. I've seen on TW forums that some people aren't having issues, some are just putting a cut piece of plastic between the grill garnish and the TSS which fixes it.

Looking to see what y'all are doing? Are you just running the TSS TRD OEM Garnish?
 

hellppy

= VI • Diamond
T3G Supporter
Messages
558
Location
Scottsdale, AZ
First Name
Sean
T3G Member
#644
I should start by saying that, I've got a champagne taste on a water budget so I went with an eBay TRD Pro Grille... the quality is decent but as expected I'm having an issue with intermittent TSS warnings. I've seen on TW forums that some people aren't having issues, some are just putting a cut piece of plastic between the grill garnish and the TSS which fixes it.

Looking to see what y'all are doing? Are you just running the TSS TRD OEM Garnish?
Hmm, that's strange, I haven't heard of the extra piece of plastic fix. I'm running the OEM grille and garnish so I've never had any TSS issues. My buddy MMoreno16 is running the China eBay grille and I don't think he's had any issues either.
 

hallux

= IV • Gold
Messages
237
First Name
Das Big Toe
T3G Member
#1,649
Hmm, that's strange, I haven't heard of the extra piece of plastic fix. I'm running the OEM grille and garnish so I've never had any TSS issues. My buddy @MMoreno16 is running the China eBay grille and I don't think he's had any issues either.

Weird, maybe he's got an idea cause while I don't mind the OEM TSS garnish, it just doesn't make sense why its glossy :(
 

Jesse Rizo

= VI • Diamond
T3G Supporter
Messages
534
Location
Inland empire,ca
First Name
Jesse
T3G Member
#1,068
I should start by saying that, I've got a champagne taste on a water budget so I went with an eBay TRD Pro Grille... the quality is decent but as expected I'm having an issue with intermittent TSS warnings. I've seen on TW forums that some people aren't having issues, some are just putting a cut piece of plastic between the grill garnish and the TSS which fixes it.

Looking to see what y'all are doing? Are you just running the TSS TRD OEM Garnish?
I’m running the oem garnish with a $100 ebay trd grill and so far it’s perfect only one time it went wild and that was when I went threw some deep mud but besides that it’s worked great so far I gotta keep crossing my fingers lol
 

Jesse Rizo

= VI • Diamond
T3G Supporter
Messages
534
Location
Inland empire,ca
First Name
Jesse
T3G Member
#1,068
Weird, maybe he's got an idea cause while I don't mind the OEM TSS garnish, it just doesn't make sense why its glossy :(
You get use to it first day of install I was like hell na but after I’ve ended up adjusting to it and I’ve asked people if they notice anything g funky when looking at the grill they won’t even notice the garnish until I mention it so I felt better about that as well
 

hallux

= IV • Gold
Messages
237
First Name
Das Big Toe
T3G Member
#1,649
You get use to it first day of install I was like hell na but after I’ve ended up adjusting to it and I’ve asked people if they notice anything g funky when looking at the grill they won’t even notice the garnish until I mention it so I felt better about that as well
I’m running the oem garnish with a $100 ebay trd grill and so far it’s perfect only one time it went wild and that was when I went threw some deep mud but besides that it’s worked great so far I gotta keep crossing my fingers lol
Yeah maybe I'll just grab it, it's like $55.00 on eBay... I should call my local stealership and see what they get it for. I just know that I want all the TSS stuff to work because well...why buy a $38k truck with a feature you can't use right? lol
 

hallux

= IV • Gold
Messages
237
First Name
Das Big Toe
T3G Member
#1,649
I'll tell ya man, I feel kinda bad for these dealerships that can't compete with the online market... Just called the local dealership about the garnish and they want $72.00 and that's marked down! I told the guy that eBay has one OEM with the part number and shit straight from Toyota for $52.00 shipped...
 

Jesse Rizo

= VI • Diamond
T3G Supporter
Messages
534
Location
Inland empire,ca
First Name
Jesse
T3G Member
#1,068
I'll tell ya man, I feel kinda bad for these dealerships that can't compete with the online market... Just called the local dealership about the garnish and they want $72.00 and that's marked down! I told the guy that eBay has one OEM with the part number and shit straight from Toyota for $52.00 shipped...
Yea that’s where i got my garnish as well off eBay lol I do feel bad though but hey we all gotta save money some how when possible only way to make more $ in the end
 

hellppy

= VI • Diamond
T3G Supporter
Messages
558
Location
Scottsdale, AZ
First Name
Sean
T3G Member
#644
I'll tell ya man, I feel kinda bad for these dealerships that can't compete with the online market... Just called the local dealership about the garnish and they want $72.00 and that's marked down! I told the guy that eBay has one OEM with the part number and shit straight from Toyota for $52.00 shipped...
Usually most dealerships have way lower prices online for parts. Go to your dealership parts website and search part number 5314135060.

Couple random examples:
https://parts.bommaritotoyota.net/p...DIATOR-GRILLE---NO-1/71694366/5314135060.html
https://toyotaparts.bochtoyotasouth.com/oem-parts/toyota-lower-trim-5314135060
https://parts.westcoasttoyotalb.com...DIATOR-GRILLE---NO-1/71694366/5314135060.html
 

Tyler

= IX • Paragon
Badministrator
T3G O.G.
Messages
5,941
Location
Long Island, NY
First Name
Tyler
Military
Marine Corps (Vet.)
Build Thread
(Click to View)
T3G Member
#1
hallux did you manage to fix it?
 

JamesR913

= IV • Gold
Messages
137
Location
SE CT
First Name
James
Military
Navy (Vet.)
T3G Member
#1,512
I installed the mad hornets faux pro grille and did not go with the garnish after reading that the alert would clear itself after approximately 100 miles. The was was installed with 900 and something miles, I don't remember the specific number and today I went over 1100 miles. The weird thing is the PCS off light will come on after driving a few minutes then clear it self, then randomly come back on. A couple times it came on while I had dynamic cruise active and then cleared a few miles later. I would understand this behavior if it was raining or snowing but it is cold and clear here today and I am driving on paved roads so nothing is getting kicked up on the sensor. Any ideas? Should I just spring for the garnish?
 

Jesse Rizo

= VI • Diamond
T3G Supporter
Messages
534
Location
Inland empire,ca
First Name
Jesse
T3G Member
#1,068
I installed the mad hornets faux pro grille and did not go with the garnish after reading that the alert would clear itself after approximately 100 miles. The was was installed with 900 and something miles, I don't remember the specific number and today I went over 1100 miles. The weird thing is the PCS off light will come on after driving a few minutes then clear it self, then randomly come back on. A couple times it came on while I had dynamic cruise active and then cleared a few miles later. I would understand this behavior if it was raining or snowing but it is cold and clear here today and I am driving on paved roads so nothing is getting kicked up on the sensor. Any ideas? Should I just spring for the garnish?
Get the garnish that’s forsure but try disconnecting the sensor (vehicle off) and reconnect it turn on vehicle see if it helps probably just needs to reset itself hope it helps ?
 

Jesse Rizo

= VI • Diamond
T3G Supporter
Messages
534
Location
Inland empire,ca
First Name
Jesse
T3G Member
#1,068

JamesR913

= IV • Gold
Messages
137
Location
SE CT
First Name
James
Military
Navy (Vet.)
T3G Member
#1,512
Thanks for the link to the garnish just added it to an order I was making for my other project car. 1966 GTO
 
Top Bottom