• Welcome to Tacoma3G.com, a free resource for 2016-2023 Toyota Tacoma owners!

    This website is the passion-project of a USMC veteran/mechanic, @Tyler. I created Tacoma3G.com to share my knowledge of this subject with others and to provide like-minded folks with a comfortable space to ask questions and create 'build threads' within our Tacoma Forums. Now, if the format of this website is confusing to navigate for you, or if you're interested in my full mission and T3G's history, check out the Help and About pages.

Grille TRD Pro Grille - TSS Issue

hallux

4️⃣ Gold
I should start by saying that, I've got a champagne taste on a water budget so I went with an eBay TRD Pro Grille... the quality is decent but as expected I'm having an issue with intermittent TSS warnings. I've seen on TW forums that some people aren't having issues, some are just putting a cut piece of plastic between the grill garnish and the TSS which fixes it.

Looking to see what y'all are doing? Are you just running the TSS TRD OEM Garnish?
 
I should start by saying that, I've got a champagne taste on a water budget so I went with an eBay TRD Pro Grille... the quality is decent but as expected I'm having an issue with intermittent TSS warnings. I've seen on TW forums that some people aren't having issues, some are just putting a cut piece of plastic between the grill garnish and the TSS which fixes it.

Looking to see what y'all are doing? Are you just running the TSS TRD OEM Garnish?
Hmm, that's strange, I haven't heard of the extra piece of plastic fix. I'm running the OEM grille and garnish so I've never had any TSS issues. My buddy @MMoreno16 is running the China eBay grille and I don't think he's had any issues either.
 
Hmm, that's strange, I haven't heard of the extra piece of plastic fix. I'm running the OEM grille and garnish so I've never had any TSS issues. My buddy @MMoreno16 is running the China eBay grille and I don't think he's had any issues either.

Weird, maybe he's got an idea cause while I don't mind the OEM TSS garnish, it just doesn't make sense why its glossy :(
 
I should start by saying that, I've got a champagne taste on a water budget so I went with an eBay TRD Pro Grille... the quality is decent but as expected I'm having an issue with intermittent TSS warnings. I've seen on TW forums that some people aren't having issues, some are just putting a cut piece of plastic between the grill garnish and the TSS which fixes it.

Looking to see what y'all are doing? Are you just running the TSS TRD OEM Garnish?
I’m running the oem garnish with a $100 ebay trd grill and so far it’s perfect only one time it went wild and that was when I went threw some deep mud but besides that it’s worked great so far I gotta keep crossing my fingers lol
 
Weird, maybe he's got an idea cause while I don't mind the OEM TSS garnish, it just doesn't make sense why its glossy :(
You get use to it first day of install I was like hell na but after I’ve ended up adjusting to it and I’ve asked people if they notice anything g funky when looking at the grill they won’t even notice the garnish until I mention it so I felt better about that as well
 
You get use to it first day of install I was like hell na but after I’ve ended up adjusting to it and I’ve asked people if they notice anything g funky when looking at the grill they won’t even notice the garnish until I mention it so I felt better about that as well
I’m running the oem garnish with a $100 ebay trd grill and so far it’s perfect only one time it went wild and that was when I went threw some deep mud but besides that it’s worked great so far I gotta keep crossing my fingers lol
Yeah maybe I'll just grab it, it's like $55.00 on eBay... I should call my local stealership and see what they get it for. I just know that I want all the TSS stuff to work because well...why buy a $38k truck with a feature you can't use right? lol
 
I'll tell ya man, I feel kinda bad for these dealerships that can't compete with the online market... Just called the local dealership about the garnish and they want $72.00 and that's marked down! I told the guy that eBay has one OEM with the part number and shit straight from Toyota for $52.00 shipped...
 
I'll tell ya man, I feel kinda bad for these dealerships that can't compete with the online market... Just called the local dealership about the garnish and they want $72.00 and that's marked down! I told the guy that eBay has one OEM with the part number and shit straight from Toyota for $52.00 shipped...
Yea that’s where i got my garnish as well off eBay lol I do feel bad though but hey we all gotta save money some how when possible only way to make more $ in the end
 
I'll tell ya man, I feel kinda bad for these dealerships that can't compete with the online market... Just called the local dealership about the garnish and they want $72.00 and that's marked down! I told the guy that eBay has one OEM with the part number and shit straight from Toyota for $52.00 shipped...
Usually most dealerships have way lower prices online for parts. Go to your dealership parts website and search part number 5314135060.

Couple random examples:
https://parts.bommaritotoyota.net/p...DIATOR-GRILLE---NO-1/71694366/5314135060.html
https://toyotaparts.bochtoyotasouth.com/oem-parts/toyota-lower-trim-5314135060
https://parts.westcoasttoyotalb.com...DIATOR-GRILLE---NO-1/71694366/5314135060.html
 
I installed the mad hornets faux pro grille and did not go with the garnish after reading that the alert would clear itself after approximately 100 miles. The was was installed with 900 and something miles, I don't remember the specific number and today I went over 1100 miles. The weird thing is the PCS off light will come on after driving a few minutes then clear it self, then randomly come back on. A couple times it came on while I had dynamic cruise active and then cleared a few miles later. I would understand this behavior if it was raining or snowing but it is cold and clear here today and I am driving on paved roads so nothing is getting kicked up on the sensor. Any ideas? Should I just spring for the garnish?
 
I installed the mad hornets faux pro grille and did not go with the garnish after reading that the alert would clear itself after approximately 100 miles. The was was installed with 900 and something miles, I don't remember the specific number and today I went over 1100 miles. The weird thing is the PCS off light will come on after driving a few minutes then clear it self, then randomly come back on. A couple times it came on while I had dynamic cruise active and then cleared a few miles later. I would understand this behavior if it was raining or snowing but it is cold and clear here today and I am driving on paved roads so nothing is getting kicked up on the sensor. Any ideas? Should I just spring for the garnish?
Get the garnish that’s forsure but try disconnecting the sensor (vehicle off) and reconnect it turn on vehicle see if it helps probably just needs to reset itself hope it helps ?
 
I just wanted to drop some information here that may help others... I might have found a DIY Hackjob way of tricking the system which I wouldn't completely recommend. The reason I say this is because I do not want to take any responsibility if something fails or Toyota tells you to pound sand if you have an issue.

That being said, all disclosure aside what I did was simply cut a small piece of plastic (about the same size of the radar device) and place it in against it with some black duct tape. Yes, you read that correctly... I duct taped a piece of plastic to it... Haha

So far I do not get nearly as many warnings as I used to that the TSS (Toyota Safety Sense) or PCS (Pre-Collision System) not working. I have tested the adaptive cruise control w/ no issues and the PCS does in fact work for me. I do find that it sometimes triggers the PCS at incorrect times leading the dash warning of BRAKE! to come up and the system to alert me and the power / brakes to be mildly applied. That being said it commonly clears up within 10 - 15 seconds.
 
Having this same issue. Bought faux grille from Mad Hornets with garnish. Install was fine, looks great, but PCS off light shows on dash. I've read/ heard that it takes about a week or roughly 100 miles to adapt to new garnish, but just curious if anyone has heard differently. I have put about 60 miles on it since I put the new grille on.
 
Delaership
Is replacing my sensor right now. I had to fight with them but they are. FYI... I had no idea but I just found out if you hold your cruise button in for 3-5 seconds your cruise control will work with out the sensor
Did your sensor come bad from the factory? I thought about if I ever needed to get it fixed, what the dealer would say, or if they would even notice that it’s not an oem grille lol.
My PCS went off today right after replying to previous thread quote, made me stoked that it still works....and then went back to showing unavailable with the orange “off” light on the dash.
 
Thanks for the reassurance haha. I should be taking a trip down south to San Diego this weekend so that’ll give it some time to recalibrate.

Make sure that your garnish is squared up with the sensor. I had hell for weeks trying to get mine working without error codes. Eye ball it until it’s square with the grill, clear code with a scan tool if said tool reads a code, and carry on. Worked for me after three weeks of screwing with it and having dealer look at the issue with no solution.
 
Top